Viewing 6 posts - 1 through 6 (of 6 total)
  • Author
    Posts
  • #26269
    ienaxxx
    Supported

    Hello, i installed your theme and the example content, following your Guide at https://wpdocs.gitbook.io/wi-help/download-and-installation/install-theme-and-active

    I installed it first in a copy under my localhost Ubuntu 20.04 LTS with both lampp 5.6.40(not working, see at the end) and 8.0.7 (installation ok, but site doesn’t work) and, under lampp 8.0.7:

    #1 : the site, after importing the demo content, doesn’t work.
    #2 : by deactivating the Elementor Header & Footer Builder plugin, I’m able to see just the OLD PAGES (that doesn’t use Elementor).

    I will not, obviously, install it online until this problem is solved, because it’s going to break my site.

    How can we proceed to resolve the issues?

    P.S.
    under lampp 5.6.40 it doesn’t work at all, neither the preview. It stops calling an exception in merlin-config.php row 198 in which indeed there’s a notation which is probably incompatible with PHP 5.6:
    $selected_import = ($this->import_files())[$selected_import];

    #26272
    ienaxxx
    Supported

    I tried also to install a fresh version of WordPress, always in localhost, and it doesn’t work, neither this way.

    #26297

    Hi,

    Currently our themes are not compatible with PHP version 8.0, so when you import data, it will cause an error and cannot be imported.
    Please use PHP 7.4 version for your website

    #26561
    ienaxxx
    Supported

    In your own wiki you don’t state that:
    https://wpdocs.gitbook.io/wi-help/get-started/requirements

    • WordPress 5.2+
    • PHP 5.6+
    • MySQL 5.6+

    PHP 7.4 IS NOT SUPPORTED ANY MORE SINCE Nov, 28th 2021! This means that, if a new vulnerability is found, that applies to our hosting, we’ll not be able to fix it or we’d break the template!

    AND your theme is not compatible with PHP 5.6, neither, as per said before.

    You better retire a template, once it’s not compatible with the current standards anymore, if you don’t plan to maintain it.
    It’s cheaper than others but you get much less, AND a headache for sure.
    If you stated the compatibility RIGHT from the beginning (assuming it’ll work, with PHP 7.4), there would have been no problems: we would have chosen another template.

    I’ll let you know if it works with PHP 7.4

    #26567
    ienaxxx
    Supported

    Warning: array_merge(): Expected parameter 2 to be an array, string given in /opt/lampp7.4.29/htdocs/amicidelvillaggio.it/wp-content/plugins/elementor/includes/managers/controls.php on line 776

    This is an error visualized while editing pages with elementor and viewing the site while logged in.

    Apart from that:

    • The import worked with PHP7.4.29
    • The plugins installation step failed with Elementor header&… and Mailchimp
      • The second Attempt worked, installing the 2 missing plugins
    • During the plugins installation, WooCommerce asked for shop business details. This could be OK
    #26568

    PHP 7.4 is currently stable version and compatible with most plugins and themes. We are planning to test and update themes that are compatible with PHP 8.0, but this also depends on plugins and wordpress core, currently plugins are not 100% compatible with PHP 8.0.
    We will ensure that our customers can use PHP 8.0 before version 7.4 is no longer supported.

Viewing 6 posts - 1 through 6 (of 6 total)

You must be logged in to reply to this topic.